FAQ und L?sungsans?tze zu "Der Anzeigetreiber wurde nach einem Fehler wiederhergestellt"

  • Hallo liebe Community,


    dem einen oder anderen ist sicherlich im Betrieb von Windows folgender Fehler aufgetreten, der so aussehen kann:








    Symptome:
    Die Symptome sind wie folgt: selbst im 2D-Modus wenn man auf dem Desktop arbeitet, wird der komplette Bildschirm pl?tzlich schwarz, und nach paar Sekunden kommt wieder das Bild. Im schlimmsten Fall erscheint dann die Fehlermeldung unten rechts in der Symbol-Leiste mit der Meldung "Der Anzeigetreiber wurde nach einem Fehler wiederhergestellt".


    Ich z.B. kann den Fehler auch reproduzieren, indem ich meinem FSX Bufferpools 0 zuweise, und die Grafikeinstellungen soweit hochdrehe, dass der FSX irgendwann nur noch ein schwarzes Bild liefert oder abst?rzt. Wenn ich auf dem Desktop lande, hab ich ebenfalls diese Fehlermeldung. Aber meistens kommt das wirklich w?hrend dem Arbeiten auf dem Windows Desktop vor. Manch anderer kann den Fehler reproduzieren, indem er Videos anschaut (z.B. auf YouTube, oder mit sonstigem Videoplayer) oder bei bestimmten 3D-Anwendungen (z.B. Games).


    Er tritt nur in Verbindung mit Windows Vista oder Windows 7 auf. Viele vermuten st?ndig fehlerhafte Treiberarchitektur oder eben nicht ausgereifte Treiberversionen. Manche sagen es h?tte was mit falscher ?bertaktung zu tun, usw... Es tritt in den verschiedenen Systemen und Konstellationen auf. Dabei liegt das Problem weder bei ATI noch bei nVidia, sondern schlichtweg bei Windows selbst.


    Ursache:
    Seit Windows Vista wurde eine Funktion eingef?hrt, die laut Microsoft harte Systemabst?rze verhindern soll. Wenn das OS h?ngende Treiber erkennt, l?dt er diese automatisch neu, bevor der Rechner komplett den Dienst mit einem Bluescreen und Freezer quittiert. Das gilt auch f?r andere Hardwarekomponenten, wie z.B. Soundkarten, oder USB-Ger?te.


    L?sungsvorschl?ge:


    (1.) Deaktivieren des Timeouts ?ber die Windows-Registry


    die folgenden Werte sind in der Registry NICHT vorhanden und m?ssen daher angelegt werden, damit die internen Timeouts von Windows ausgehebelt werden. Dieser L?sungsansatz funktioniert bei den Meisten, Erfolgsquote ?ber 75%. Ich biete euch hier eine fertige Registrierungsdatei an. Nachdem ihr diese heruntergeladen habt, einfach doppelklick darauf und die Aufforderung best?tigen. Daraufhin werden die in der Datei angegeben Schl?ssel abge?ndert. Das erfolgt nat?rlich auf eigene Gefahr und ohne jeglicher Gew?hr! Jeder muss f?r sich selbst wissen, ob und in welchem Umfang er ?nderungen an der Windows-Registry durchf?hrt. Dies nur so als Anmerkung. Trotz allem versichere ich, dass die Registry-Eintr?ge sauber sind, und kein Schabernack an eurem Windows betrieben wird :) Wer die ?nderungen r?ckg?ngig machen m?chte, um den urspr?nglichen Zustand wiederherzustellen, kann diese ebenso durchf?hren. Ich biete euch hier beide Registry-Dateien zur freien Verf?gung zum Download an.


    Registrydatei um die internen Windows-TimeOuts zu entfernen


    Registrydatei um die internen Windows-TimeOuts wiederherzustellen


    Die technischen Hintergrundinformationen zu diesen Timeouts sind auf den Tech-Seiten von Microsoft hier zu finden:


    Timeout Detection and Recovery of GPUs through WDDM



    (2) Ausschalten des C-State-Support im BIOS:


    Bei manchen soll es auch geholfen haben, den C-State-Support (C1E) im BIOS ausgeschaltet zu haben. Bei meinem BIOS meines Motherboards heisst es z.B. "Intel C-STATE Technology" Hintergrundinformationen zum C1E sind HIER zu finden.


    (3) Deaktivieren des Dienstes bei ATI-Usern:


    Einige ATI-User berichteten, dass es geholfen hat den ehemaligen "ATI-Hotkey-Poller"-Dienst zu deaktiveren. Dieser heisst jetzt "AMD External Events Utility". Wie die Erfolgsquote hier ausschaut weiss ich selbst nicht. Einfach mal probieren, falls die ersten zwei M?glichkeiten versagen.




    Ich hoffe hiermit dem einen oder anderen geholfen haben zu k?nnen. Bei weiteren Anregungen, Tips, Tricks oder sonstigen Hilfestellungen meldet euch einfach.


    Gefl?gelte Gr?sse,
    Pegasus.

  • Hey Pegasus,


    Super danke erst mal f?r deine m?he hier, trotzdem bin ich immer skeptisch mit dem Regi...!


    Funzt das wirklich auch mit dem r?ck?ndern wieder weil m?chte nicht noch die tage mein system neu drauf spielen.


    Hast du es auch so gemacht?? Und keine Probleme gehabt??


    Meld dich mal dazu bitte


    Gru?
    Mario

  • Hallo Mario,


    ich habe den Registry-Eintrag durchgef?hrt und bis jetzt scheint's bei mir geklappt zu haben. Ich hab keinen schwarzen Bildschirm mehr zu Gesicht bekommen :)


    Ob du das nun ausf?hren m?chtest oder nicht, das musst du selbst wissen. Diese Entscheidung kann ich dir nicht abnehmen. Wenn du skeptisch bist, les dir doch einfach die Infos von Microsoft durch. Vielleicht hilft dir das bei deiner Entscheidung.


    Viele liebe Gr?sse,
    Pegasus.

  • Hi Pegasus


    Vielen vielen Dank f?r deinen L?sungsvorschlag. Ich suche auch bereits seit l?ngerem eine L?sung daf?r. Bei mir trat der Fehler bisher nur in 3D-Anwendungen auf, w?hrend normalem Desktop-Arbeiten nicht.


    Ich werde es heute Abend gleich testen und nachher berichten. W?re nat?rlich super, da mich dieses Problem auch schon fast zur Verzweiflung trieb :rolleyes: Ich habe den Fehler bisher auch immer bei Nvidia gesucht. Habe andere Treiber ausprobiert, Aero abgeschaltet, alles ohne Erfolg.


    Bin gespannt, ob es funktioniert.

  • Hallo noch mal


    hab gerade wieder eine Absturz vom System gehabt wo dann drin steht FSX hat schwierigen Fehler verursacht.....


    K?nnt ihr damit was anfangen:


    Beschreibung
    Aufgrund eines Videohardwareproblems ist Windows nicht mehr voll funktionsf?hig.


    Problemsignatur
    Problemereignisame: LiveKernelEvent
    Betriebsystemversion: 6.1.7600.2.0.0.256.48
    Gebietsschema-ID: 1031


    Weitere Informationen ?ber das Problem
    BCCode: 117
    BCP1: FFFFFA800BF9C220
    BCP2: FFFFF8800FF73230
    BCP3: 0000000000000000
    BCP4: 0000000000000000
    OS Version: 6_1_7600
    Service Pack: 0_0
    Product: 256_1
    Bucket-ID: X64_0x117_Tdr:2_IMAGE_nvlddmkm.sys
    Serverinformationen: e6acf33c-725b-4bcb-8f8b-287994570628

  • Hallo zusammen


    Ich habe den von Pegasus bereitgestellten Registry-Eintrag durchgef?hrt. Nachfolgend meine Erfahrungen damit:


    Seit dieser ?nderung trat zwar kein pl?tzlicher schwarzer Bildschirm mehr auf, aber daf?r hatte ich andere Probleme. Bin zweimal von Amsterdam aus gestartet und beides mal trat folgendes auf: Nach gef?hlten 5min nach Take-Off blieb mein PC komplett h?ngen, das Bild des FS9 war zwar noch vorhanden, jedoch tat sich nichts mehr. Ich konnte nicht mal den Taskmanager aufrufen, um den FS zu beenden. Per Alt + Tab auf den Desktop wechseln ging auch nicht. Somit musste ich beides Mal den PC resetten, was nat?rlich sehr m?hsam ist (vorallem wenn das nach 10 Stunden Flug passieren w?rde).


    Deshalb habe ich am Wochenende den Registry-Eintrag wieder r?ckg?ngig gemacht. Seither habe ich zwar ab und an wieder einen schwarzen Bildschirm, jedoch l?uft der FS dann immerhin noch weiter. Dies ist das kleinere ?bel.


    Ich habe festgestellt, dass bei mir dieser schwarze Bildschirm haupts?chlich w?hrend Start / Landung passiert, also dann wenn ich durch die Wolken steige und der FS viel zu rechnen hat. Im Reiseflug passierte dies glaube ich noch nie.


    Im Netz habe ich noch den Tipp gefunden, die Spannung der Northbridge zu erh?hen. Ich habe dies tempor?r von Auto auf 1.55V und 1.60V gestellt. Jedoch treten immer noch diese Bildausf?lle auf. Was ebenfalls komisch ist, ist das bei mir in der Taskleiste nach so einem Fall zwar dieses gelbe Dreiecksymbol mit ! erscheint, wenn ich dar?ber fahre oder doppelklicke aber keine Meldung angezeigt bekomme.


    Vieleicht hat jemand noch einen anderen L?sungsansatz. Ich k?nnte auch den zweiten Vorschlag von Pegasus noch ausprobieren, mit der ?nderung im BIOS. Ich bin da jedoch immer etwas vorsichtig was solche ?nderungen angeht.

  • Das Problem nervt seit Win Vista.


    nur hatte ich das noch nie im 3D Betrieb sondern immer nur mit einer Anwendung: "Jetaudio" (mein favorisierter mp3- und Videoplayer, converter usw.)


    und nicht beim Start der Anwendung (wie h?ngende Treiber vielleicht erkl?ren k?nnten) sondern immer mitten drinn im Song.


    Ich muss in den n?chsten Tagen vom W7 RC umsteigen und hatte gehofft, dass das Problem mit dem RTM gel?st sein wird. Das scheint nicht der Fall zu sein.*seufz*


    D.h. ich muss am Laptop XP wieder parallel installieren. Wenn mir auf einer Pr?sentation der Rechner abschmiert macht das keinen schlanken Fu? :rolleyes:

    "It was wonderful to find America, but it would have been more wonderful to miss it." [Mark Twain 1894]

  • Auch ich habe dieses Problem am Anfang mit Vista 64 bit gehabt.
    Da vor knapp zwei(?) Jahren fast t?glich neue Treiber f?r Vista 64 heraus kamen,war das Problem nach dem 4. oder 5. Treiber passe.
    Da? diese Fehlermeldung also ?berhaupt nichts mit den Treibern zu tun haben soll-wer wei??
    Trotzdem auch von mir Dank f?r Deine sehr ausf?hrlichen Posts :thumbsup:
    Scott

  • Hallo Menox,


    ich habe genau dasselbe Problem. Nur bei mir kann ich es nicht r?ckg?ngig machen mit den Registry-Eintr?gen. Jetzt kann ich leider nicht spielen
    Kann mir vielleicht jemand von euch weiterhelfen, den ich komme nicht weiter. HELP! Please HELP!


    Gru? flo498

  • Hallo,
    habe das Problem auch, seitdem ich Windows Vista neu aufgesetzt habe! Bei mir immer in Verbindung mit Flackern des Bildschirms. Ich kann die Datei nicht ausf?hren, weil es bei mir eine txt-Datei ist!


    Martin

    Mit freundlichen Gr??en
    Martin, Flight!-Team

    Remember the Prime Directive of Netiquette: Those are real people out there.

  • Hallo,
    habe das Problem auch, seitdem ich Windows Vista neu aufgesetzt habe! Bei mir immer in Verbindung mit Flackern des Bildschirms. Ich kann die Datei nicht ausf?hren, weil es bei mir eine txt-Datei ist!


    Martin

    Also du musst den Textinhalt nochmal selber kopieren, in ein neues Text-Programm einf?gen (am besten Editor) und dann Datei --> Speichern unter... --> in das obere
    Textfeld eingeben: z.B. Timeout.reg ---> speichern. Dann ausf?hren und dann m?sste es klappen.

  • Hallo Menox,


    ich habe genau dasselbe Problem. Nur bei mir kann ich es nicht r?ckg?ngig machen mit den Registry-Eintr?gen. Jetzt kann ich leider nicht spielen
    Kann mir vielleicht jemand von euch weiterhelfen, denn ich komme nicht weiter. HELP! Please HELP!


    Gru? flo498

    Muss noch was erg?nzen: Benutze Windows 7 (64-bit)

  • Wenn die heruntergeladene Datei so hei?t:


    timeout_registry_anpassen_www.przeklej.pl.reg.txt


    einfach hinten das .txt weg und es hei?t dann:


    timeout_registry_anpassen_www.przeklej.pl.reg


    fertig.

    MfG
    Dr. f.s. Sandra Marion R.
    Polygon-Dompteuse


    Hurrraaaaa - es wird Morgens hell und Abends dunkel.

  • Hallo,
    danke, es klappt! Jedenfalls seit 5 Minuten kein Flackern:) Das gabs schon lange nicht mehr! Aspropos: Bei mir ist es nie aufgetreten, wenn der FS oder ein anderes Spiel liefen!?


    Martin

    Mit freundlichen Gr??en
    Martin, Flight!-Team

    Remember the Prime Directive of Netiquette: Those are real people out there.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!