Bildruckler bei 90 fps?! bzw modernem PC?

    • Sunrise69 schrieb:

      Ja ich habe alles am aktuellen Stand. Grafiktreiber, Plugins etc...


      Sunrise, hattest du meine Beiträge genau gelesen? du musst die plugins zunächst mal deaktivieren, um den Störfaktor zu finden. Ich bin mir nicht so sicher, ob der treiber die ursache ist.

      Sunrise69 schrieb:

      Habe in unregelmäßigen Zeitabständen Hänger für 1-2 Sekunden


      kannst du das noch etwas genauer definieren? Wenn die Ruckler nur ca. alle 15 min. kommen, ist es evtl. nur nachladende szenerie.
    • Habe ich alles schon probiert mit den Plugins abschalten ändert nichts dran.

      Im Schnitt sind es bei mir 40-100 Frames, je nach Gebiet. Und alle 1-2 Minuten brechen die Frames mal ein auf 5-10 dann hängt das ganze 1-2 Sekunden und dann geht es wieder normal weiter.

      Dürfte wohl wirklich an Nvidia bzw dessen Treiber liegen, mein System ist mit einem i7 mit 4,5 Ghz, 16 GB Ram und einer GTX 970 stark genug. Noch dazu habe ich die Grafikeinstellungen nicht auf Maximum laufen.
    • Hallo Manuel

      Die meisten Bildschirme haben eine Frequenz von 60 Hz. Du kannst die FPS also ruhig auf diesen Wert beschränken. Es bringt nichts, wenn die Grafikkarte mehr Bilder berechnet als sie anzeigen kann.

      Läuft die Festplatte in der Zeit, wenn du die Ruckler hast? Bei vielen PC hast du vorne eine gelb blinkende Lampe für die Festplatte. Beim FSX hatte ich auch solche Ruckler genau jede Minute, die vom nachladen von Scenerie kommt. Falls du eine SSD hast, sollte das aber nicht das Problem sein.

      viele Grüsse Martin
      viele Grüsse Martin

      Flugsimulator-PC und Zubehör je nach Budget (Stand: 03.12.2017)
      Flight Simulator X - richtig einstellen und verstehen (Stand: 10.10.2017)

      i5-4670K @4.0 GHz, 12 GB RAM, ASUS 660 GTX, 2 Bildschirme, W 7 64-bit
    • Hi

      Der Prozessor dürfte eine interne Grafikeinheit haben. Ist die vielleicht im BIOS eingeschaltet und der zugehörige Intel-Treiber nicht (richtig) installiert? Ggf. im Gerätemanager prüfen oder die interne Grafikeinheit im BIOS deaktivieren. Das kann auch schon mal zu Rucklern führen.

      Gruß
      Jörg
      Happy flying
      Jörg


      Meine Hardware:
      Gehäuse: Cooler Master Centurion 5 II, Motherboard: ASUS P8Z77-V (Sockel 1155), Prozessor: Intel Core i7-3770K, GraKa: Gigabyte Radeon R9 390 G1 Gaming 8GB, Festplatten: SAMSUNG SSD 830 256 GB und Seagate Barracuda 7200 1000 GB, Speicher: 16 GB-Kit Corsair Vengeance DDR3 1600 MHz CL9, OS: Windows 10 Professional 64-bit
    • Es ist schon ein Unterschied zwischen FP's und der Rate vom Monitor.
      60mal das gleiche Bild pro Sekunde erkennt logischerweise das Auge nicht. Anders bei Bewegung. Haben wir weniger Frames zur Verfügung, dann entsteht der Eindruck von Sprüngen. Dazu müssen wir bedenken, was die Simulation alles berechnen muss. Ausser den Daten für die Flugdynamik muss STÄNDIG jedes Frame gerendert werden. Das in beliebiger Höhe und mit unterschiedlichen Sichten, weltweit. Eine "normale" Spielewelt ist einfacher aufgebaut. Je mehr (Frames) die Grafikkarte hier berechnen kann, desto besser und "flüssiger" wahrnehmbar.
      Die wichtigste Einstellung ist daher eigentlich ein Synchronisation zwischen Grafikkarte und Monitor (vSync). Damit wird genau bei einem neuen Bild die Information von der Grafikkarte abgerufen. Idealerweise ist keine Unterbrechung erkennbar. Zusätzlich "stört" das ganze eine zu langsamer Abruf der nötigen Informationen, zusätzliche "Sprünge" im Ablauf des Programms (Einspielen von Wetter, AI-Fliegern usw), sowie weitere nachträgliche bildliche Bearbeitung (Filterungen usw). So kommen mit "Ausbau" des Flugsimulators ständig weitere kleine Hürden dazu und bescheren die Ruckler, Wackler und Aussetzer.
      In der Fernsehtechnik ist es ähnlich, da laufen die auch auf 200 Hz, obwohl der Bildaufbau nur 50 Hz hat. Bei großen Diagonalen rechnet hier ein Zwischenspeicher Bildpositionen dazu ...
    • In diesem Zusammenhang (Bildruckler) bei unterstellen wir mal Überleistung, ist die Frage nicht schlecht,
      kann die FPS beim Bildaufbau im X-Plane begrenzt werden?
      Sozusagen wird die Leistung nicht unendlich in die GraKa gesteckt sondern in den eigentlichen Flusi freigestellt.

      Gehr das im X-Plane?

      Joachim
    • Hallo zusammen,

      auch ich habe mit v10.35 (64bit) die gleichen Probleme - Bildruckler, also Framedrops bis runter zu 5fps alle 10-20 Sekunden und auch Freezes bis zu 10 Sekunden beim Nachladen von Kartensegmenten oder hier und da mal ein ctd - sehr nervig auch schon bei Kurzstreckenflügen.
      Habe vor einem Jahr mit v10.20 begonnen, damals noch mit einer GTX560 Ti mit 1GB Vram und 8GB Hauptspeicher, xp lief damals von einer normalen Festplatte und alles war gut. Um das ganze etwas schneller zu bekommen hab ich mir dann Msi GTX770 TwinFrozr mit 2GB Vram geholt, den Hauptspeicher auf 16GB Ram aufgerüstet und xp auf eine Samsung EVO840 mit 250GB gezogen. Lief nochmal nen Zacken schneller alles.
      Hab die ganzen Updates (10.25 usw.) nicht mitgemacht auf v10.30 zwar upgedatet aber dann krankheitsbedingt ca. 4 Monate nicht geflogen und vor ein paar Wochen wurde dann gleich auf 10.35 aktualisiert.
      Die Performance hat mich echt geschockt muss ich gestehen ;(

      Hab dann im x-plane.org Forum etwas nachgeforscht - diese Probleme treten wohl seit v10.30 gehäuft auf.

      Für die Framedrops wurde Treiberversion 337.88 empfohlen - meine 770er funktioniert zwar damit aber es hilft nicht gegen die Einbrüche, zweiter Tipp war
      die Thread Optimierung im Treiber zu deaktivieren - half aber auch nicht. Herabsetzen der Grafiksettings bringt's auch nicht - und meine Settings sind nun wirklich nicht hoch eingestellt - sogar über New York komme ich noch auf 30fps, hdr ist auch off... Vram Auslastung ca. 900MB, da ist noch Platz..
      Laminar schiebt das Problem auf nVidia und wie schon jemand sagte nVidia hat es nicht nötig etwas für dieses Nischenprodukt zu tun - ausserdem hat ja wohl die Mehrheit keine Probleme. Meine persönliche Meinung ist, dass es an Laminar liegt die modernen Karten richtig zu "füttern" - andere Software bringt das ja auch fertig, und mal ehrlich - selbst Games die 10 Jahre alt sind laufen immer noch mit dem neuesten Treiber, ich hatte bisher zumindest noch keine Probleme nach einem nVidia-Update.

      Die Programmhänger treten bei mir immer auf wenn ein neues "Kartenteil" geladen wird. Es scheint so als ob mit diesem, ich nenn ihn mal Sceneryloader Probleme gibt.
      Es wurde auch von Problemen beim Flug über den Nordpol berichtet, dort werden wohl gehäuft Daten nachgeladen?
      Da mein xp auf einer Evo840 Ssd liegt hab ich mal das Samsung Performance Restoration Tool laufen lassen, lt c't gab es bei dieser Ssd mal Probleme mit Read-Transfer-Einbrüchen bei älteren Dateien (Transferrate runter bis 30MB/s) - danach die magician-Software nochmal optimieren lassen und ein Performance-Check - also meine Ssd bringt bis zu 514 MB/s - sollte wohl reichen. Das hätte eine Erklärung sein können, war sie aber nicht.
      Einer der englischenForumsmoderatoren (AndyGoldstein) hat da was anklingen lassen, dass man vorhat diesen "Sceneryloader" zu überarbeiten, scheint wohl so
      dass da was nicht stimmt.

      Die ctd's traten bei mir meist auf wenn ich nicht merke das grad so ein Ladehänger stattfindet weil ich im Cockpit was verstellen will und z.B. versuche dem AP eine neue Höhe vorzugeben - klick klick klick und draussen ist man. Seitdem ich aufpasse und das unterlasse und warte bis alles geladen ist hatte ich keinen ctd mehr.

      Mir wurde auch geraten die Plugins zu deaktivieren - ich habe keine. Und ich würde erweiterte Szenerien benutzen - wüsste nicht wo ich die her hätte?
      Wenn xp sie nicht automatisch installiert, also ich hab's nicht getan.
      Es wurde auf Wärmeprobleme hingewiesen - CPU Temperatur max 51°C bei mir (Alpenföhn Matterhorn), die TwinFrozr säuselt nur vor sich hin - ich nutze auch andere Programme wo der Rechner doch etwas lauter wird und das stundenlang, Hitzefehler schliesse ich also aus.
      Was mich auch wundert ist - warum nutzt das Programm nicht den verfügbaren Hauptspeicher, ich habe meist noch 10GB frei. Da hat man schon mal 64bit und nur 4GB werden benutzt - und nein - ich fliege nicht die 32bit-Version ;) Selbst die neue Rust-Version hat schon mal fast 9 GB belegt (gut ist eine Beta)

      Vielleicht spiele ich mal DJ und installiere meine V10.20 nochmal, aber dafür ist der Leidensdruck noch nicht hoch genug, denn ich muss trotz allem gestehen - wenn es läuft sieht's fantastisch aus.

      Ich wünsch Euch was und warte derweilen auf v10.40 bzw. nVidia 370.xx ;)
    • Noch was vergessen

      Hallo nochmal,

      interessant ist es auch sich den devblog von Ben Supnik mal anzuschauen, da wird einiges
      erklärt was diese Probleme betrifft. Die Behauptung aus dem englischen Forum das Laminar die Schuld den Treiberherstellern gibt stimmt schon mal nicht.
      Ein guter Überblick über die Schwierigkeiten ab v10.30 finde ich.

      Gruß :thumbup:

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Tom1969 ()

    • Hallo,

      könnte mal jemand seine Nvidia Inspector Einstellungen posten, oder mir schreiben, was ich an Einstellungen verändern könnte, um eine bessere Leistung im x-plane zu erzielen?
      Hab eine Nvidia gtx 770 2gb karte, 16gb Ram und den i5-3570k

      Das sind meine Einstellungen im x-plane:



      Inspector:





      Danke für Eure Hilfe im vorraus!!!