Flugzeug-Lichter-Problem mit FSUIPC, SPAD, Saitek

    • FSX-SE

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Flugzeug-Lichter-Problem mit FSUIPC, SPAD, Saitek

      Neu

      Hallo zusammen, habe nach meinem speziellen Problem gesucht aber nichts passendes gefunden, daher versuche ich es mal hier im neuen Thread zu schildern.

      Vorab, ich habe FS-X STEAM Edition .. (edit nachdem ich das verfasst habe, es wird ein längerer Text :) .. )

      Generell ist mir aufgefallen, das die typischen Flugzeug-Lichter nur schwer bis garnicht per "DEFAULT" Schaltbar sind.
      Obwohl Ihr sicher bereits alle existierenden Lichter kennen dürftet, schreibe ich dennoch mal, was mir aufgefallen ist.

      Zb B 737 :

      - Landing Light - lassen sich default unter settings auf ne taste (auch joistick) legen
      - Taxi Lights - - - lassen sich auch auf taste legen
      - Strobe Lights - ebenfalls
      - Panel Lights - auch

      - die retractables und rwy turn lass ich mal beiseite -

      - Beacon Lights - lassen sich in settings NICHT belegen
      - NAVI/POS Lights - Also die rot/grüne Beleuchtung an Flügelspitze sowie die weisse am Heck EBENFALLS NICHT default zuweisbar
      - Wing Lights - (um die Triebwerkseinlässe zu beleuchten) auch nicht
      - Logo Lights - auch nicht, aber nicht schlimm da meiste freeware Flieger entsprechend gute Nachttexturen haben, wo das Licht angedeutet wird

      Drücke ich jedoch die L-Taste, gehen aber alle vorhandenen Lichter an bzw aus ..

      So nun kommt aber das "seltsame" ...

      Ich habe mir kürzlich das Saitek Switch-Panel gekauft. Hehe, meine erste Hardware die ich extra für den FluSi gekauft habe (stolz und so :) ..)
      Dort gibt es neben der netten Fahrwerksbetätigung samt Lämpchen eben so ziehmlich alle Lichter, bzw dessen Schalter..

      Diese funktionieren auch erstmal soweit gut, Ich verwende FSUIPC und SPAD.Next...
      Dadurch kann ich die nicht-benötigten Schalter (zb cowl/close) anders belegen.

      Ich habe sogar die beiden roten MASTER-Schalter (eigentlich für Bat und Alt) anders belegt und stattdessen AUTO-THROTTLE und AP-MASTER ("CMD A" - also autopilot an/aus) drauf gelegt..

      Das macht nen ILS-Anflug (ohne MCP-Hardware) echt angenehm, da ich bei TakeOff oder Approach nicht mehr mit Maus im Bildschirm agieren muss.
      (mal von Tastatur abgesehen, aber wer merkt sich schon etliche Tasten-kombies? Hardware Schalter sind "besser")

      Klappt sehr gut, könnte für "Einsteiger" ne Empfehlung sein.

      Wie dem auch sei, komme ich mal zum Licht-Problem..

      Also die Schalter vom SwitchPanel sind mittels Spad belegt und greifen auf FSUIPC-Offsets zu.

      Da habe ich derzeit folgende Zuweisungen :
      (ich verzichte mal auf das aufgedruckte Wort am Knopf und setze mal - S1, S2, S3, usw , on oder off sollte klar sein, wobei der Cowl/Close bereits S1 ist)

      S1 - Lights: Cabin (FSUIPC:0000:0D0C:512) - je nach Schalterposition entweder to ON oder to OFF
      S2 - Lights: Panel (FSUIPC:0000:0D0C:32) - hier natürlich auch on oder off
      S3 - Lights: Beacon (FSUIPC:0000:0D0C:2) - selbe spiel
      S4 - Lights: Navigation Lights (FSUIPC:0000:0D0C:1) - ....
      S5 - Lights: Strobe (FSUIPC:0000:0D0C:16) - .....
      S6 - Lights: Taxi (FSUIPC:0000:0D0C:8) - ...
      S7 - Lights: Landing (FSUIPC:0000:0D0C:4) ....

      Das bedeutet ja erstmal, dadurch das FSUIPC also für jede Beleuchtungsart nen eigenen Befehl kennt, sollte das im FSX auch gehen.
      Tut es im Grunde auch, ABER ...

      Schalte ich jetzt meinen S4 - also die rot/grün/weissen Positionslichter(Nav) AN, geht bei Nacht AUCH die Cockpit-innen-Floodlicht-Lampe MIT AN ...

      GLEICHZEITIG gehen die Strobes (Col) an den Flügelspitzen ebenfalls AN.....

      Mein S5- also Strobe-Schalter, schaltet hingegen nur das Blitzlicht am Heck, nicht jedoch jene in den Flügelspitzen..

      Schalte ich nun per Maus im VC die Wing Lights an, geht im Cockpit das helle Innen-Floodlicht aus, allerdings die Winglights gehen aber richtig an, also wie es sein sollte...

      -- Beacon, Taxi, Panel und Landing, funktionieren 100% --

      Lange Rede, kurzer Sinn: Am Saitek-Panel, FSUIPC, SPAD liegt es sicher NICHT... Da ja jeder Schalter nur seinen zugeordneten befehl via FSUIPC schickt..

      Viel eher glaube ich, das bei den Flugzeugen irgendwo Fehler sind, sprich das Lampen auf falsche Befehle reagieren, zb so:

      Lampe weiss, Strobe, rechte Tragfläche, sollte eigentlich auf den Strobe-befehl hören, aber wurde falsch programmiert und hört stattdessen auf den NAV-befehl..

      Habe das bisher in folgenden Maschienen gehabt:
      Project OpenSky - Boeing 737 - diverse Typen, Liveries, und von verschiedenen Quellen
      Project Airbus - 320, 321 usw.. ebenfalls von verschiedenen Quellen

      Default habe ich noch NICHT getestet, werde ich aber noch machen..

      Also bisher vermute ich einen Fehler, der bei den Flugzeugen entsprechend Falsch programmiert worden ist, bzw irgendwelche Configs (Panel.cfg / Aircraft.cfg / Gauges od. ä. ) einfach falsche Einträge enthalten...

      Nun meine EIGENTLICHE FRAGE ... Kann man man das irgendwie "beheben" und korrigieren ?

      Ich kann mir vorstellen, das ist sicher eine ungewöhnliche Frage, und im Grunde ist das auch nicht schlimm, fliege ich halt wie nen Weihnachtsbaum umher :)

      Wäre jedoch aber schön, wenn man das beheben könnte :)
      AMD FX 8350 @ 4,5 GHz -- Asus 970 Pro Gaming Aura -- NB + HT je 2400 MHZ
      16 Gb (2x 8 GB) HyperX Savage DDR-3 @ 1866 MHz CL-9 -- GTX 760 - MSI TwinFrozer

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Bjoern1982hl ()

    • Neu

      kurzes update:
      Dank TopGuns Hilfe konnte ich die Probleme größtenteils lösen.

      Es waren tatsächlich ein paar falsche Einträge in der Aircraft.cfg, wo Lichter zb doppelt waren.
      So zb war die Kabinenbeleuchtung (Cockpit Flutlicht / eigentlich type=4) mehrmals unter type=3(Nav) UND type=8(wing) definiert, und sone scherze...

      Logisch das dann beim schalten der Nav-Lights plötzlich das Flutlicht innen anging, aber beim schalten der Wing-Lights wieder ausging...

      Ist dem Ersteller von dem "OpenSky 737 Package" wohl nicht aufgefallen...

      Verbleibt nur noch ein einziges Problem, und zwar die Tragflächen- "Lampen" ...

      Da scheinen die Lichter direkt im Flügelmodel zu sein, und lassen sich nicht über die Aircraft.cfg ansprechen..

      Dort habe ich noch immer, das an den Flügelspitzen die STROBES immer noch mit der NAV-Lampe zusammen angehen...

      Weiss jemand, wie ich das dort noch ändern kann ?

      Alles andere jedoch konnte ich beheben und funktioniert jetzt exakt so, wie es sein sollte (und wie ich es auch möchte)
      AMD FX 8350 @ 4,5 GHz -- Asus 970 Pro Gaming Aura -- NB + HT je 2400 MHZ
      16 Gb (2x 8 GB) HyperX Savage DDR-3 @ 1866 MHz CL-9 -- GTX 760 - MSI TwinFrozer