unscharfe Texturen

    • P3Dv4-2

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • unscharfe Texturen

      Hi Leute, habe folgendes Problem:

      Es scheint mir, als würden meine Bodentexturen (ORBX) sehr langsam laden. Das macht sich vor allem im Anflug bemerkbar. Nun ist die Frage, ob es irgendwelche Tweaks (FIBER_FRAME_TIME_FRACTION etc.) gibt, die meine Texturen schneller laden lassen. Wenn ich den Sim pausiere und beispielsweise in den Einstellungen etwas ändere, sind die Texturen für wenige Sekunden scharf, aber auch nur in einem "kleinen" Radius. Nach einigen Minuten ist alles wieder matschig und es lädt nichts nach. Auch fällt auf, dass Autogen wie Bäume, Gebäude usw. schneller laden, als der Boden an sich.

      Hoffe, ihr könnt mir helfen!

      Liebe Grüße

      Max

      Meine Specs:

      i5-6500
      GTX 1060 6GB
      16 GB RAM
    • hast du die fps begrenzt? Beim FSX hab ich die Erfahrung gemacht, dass der Sim das erreichen der höchstmöglichen fps über das Szenerie laden priorisiert. Beim begrenzen auf 30 nutzt er dann die Ressourcen, die er sonst für das Erreichen von 50+ aufgewendet hätte für das Szenerie laden. Einmal hatte ich auch massive Blurrie Probleme, bei denen die Lösung ein Treiberupdate war, wenn ich mich richtig erinnere.

      Ich hab aber nur FSX Erfahrung und weiß nicht, wie sich die Dinge bei P3D verhalten. Deswegen kann ich auch nichts zu möglichen Tweaks sagen.

      PS: Dass das Autogen zuerst geladen wird ist beim FSX auch so und das nervt mich auch. Mir wären scharfe Texturen erstmal wichtiger... Leider kenn ich da keine Lösung zu
    • Hallo Max

      ich habe das nun schon von einigen gehört, dass sie mit P3D v4 Nachladeprobleme haben. Da P3D v4 deutlich mehr Szenerie in den Speicher lädt als die Version 3 stellt er bedeutend höhere Ansprüche an die Hardware.

      Die beiden wichtigsten Verbesserungsmöglichkeiten sind bereits angesprochen worden. Ich denke, bei dir dürfte vor allem eine SSD Besserung bringen. Da sehr viele kleine Dateien geladen werden müssen, muss die HD sehr viele Stellen mit dem Lesekopf anfahren. Das braucht einfach seine Zeit. Da eine SSD nur aus elektronischen Bauteilen besteht, kann sie ohne Verzögerung jeden Speicherbereich auslesen und ist bei so vielen, kleinen Dateien extrem viel schneller.
      viele Grüsse Martin

      Flugsimulator-PC und Zubehör je nach Budget (Stand: 26.05.2018)
      Flight Simulator X - richtig einstellen und verstehen (Stand: 10.10.2017)

      i5-4670K @4.0 GHz, 12 GB RAM, ASUS 660 GTX, 2 Bildschirme, W 7 64-bit
    • Hi Martin,

      danke für deine Antwort. Dann werde ich mir voll noch eine SSD kaufen müssen. Was ich jedoch krass finde ist, dass sowohl die CPU, als auch die GPU Auslastung enorm abgenommen hat, seit dem Wechsel auf die v4. CPU Auslastung ist so bei 70-80%, GPU nur bei 30-40%. Kann es damit was zu tun haben?
    • Ich würde mal intern im P3D begrenzen.
      • i7-4930K, H100, 16 GB CL9, GTX 1070, Win 7, 40" TV FullHD, TrackIR 5 & EZCA 2.6
      • P3D V4.1, FSGlobal 2010 & FMX, FTX Global & Vector & openLC EU & NA & GES & NZSI & ~ 400 airports
      • Ant's DRIF, LHC WT1, Alabeo/Carenado C152, C172, C72R, DA42, PA34, C340, C25A, PC12, ORBX LNC4, MJC DH8D, PMDG B772
      • UTL & BVAI & Traffic-GA, ASP4 & ASCA & PTA Envshade, PF3 & MCE, GSX, FSCabinCrew
    • Wenn der Prozessor auf die Festplatte warten muss, sinkt die Auslastung natürlich. Schau dir aber einmal die Auslastung aller Core einzeln an. Es kann gut sein, dass der erste Core mit dem Hauptprozess durchaus auf 100% läuft und damit die Leistung des ganzen Systems limitiert.
      viele Grüsse Martin

      Flugsimulator-PC und Zubehör je nach Budget (Stand: 26.05.2018)
      Flight Simulator X - richtig einstellen und verstehen (Stand: 10.10.2017)

      i5-4670K @4.0 GHz, 12 GB RAM, ASUS 660 GTX, 2 Bildschirme, W 7 64-bit
    • Wie ist der LoD Radius und der Autogen Radius? Seit ich beide nur mehr auf der mittleren Stufe habe, hat sich das Problem deutlich gebessert. Allerdings gabs bei mir davor Texturmatsch und das Autogen hat nicht nachgeladen. Das war bei gleichen Settings in v3 besser. Den internen Frame Begrenzer verwende ich nicht, der kostet massiv Leistung.

      Vg Martin
      Mitglied im FlightXPress Forum seit Sep 2007.
      Hardware: Intel Core i5 6600K | AMD Radeon RX470 | 8 GB DDR4 | Windows 10 64 bit
    • Der interne Begrenzer kostet ein paar FPS, ja. In meiner Erfahrung ca. 3. Ist aber - wiederum in meiner Erfahrung - die beste Mögichkeit, diese Blurries wegzubekommen (angepasste Einstellungen vorausgesetzt).
      • i7-4930K, H100, 16 GB CL9, GTX 1070, Win 7, 40" TV FullHD, TrackIR 5 & EZCA 2.6
      • P3D V4.1, FSGlobal 2010 & FMX, FTX Global & Vector & openLC EU & NA & GES & NZSI & ~ 400 airports
      • Ant's DRIF, LHC WT1, Alabeo/Carenado C152, C172, C72R, DA42, PA34, C340, C25A, PC12, ORBX LNC4, MJC DH8D, PMDG B772
      • UTL & BVAI & Traffic-GA, ASP4 & ASCA & PTA Envshade, PF3 & MCE, GSX, FSCabinCrew
    • SSD anstelle FP bringt überhaupt nichts.
      Das ist ein Problem von P3D seit V4. Gabs zwar in äteren Versionén und beim FSX auch, aber nicht so ausgeprägt.

      Bin mal mit "Y" in die Schnellverstellung gegangen, als ich unscharfe Texturen hatte. Schwebte also jetzt über diesen unscharfen Texturen. Habe dann gewartet bis die Texturen nachgeladen wurden. Dauerte 5 Minuten, Straßen wurden teilweise gar nicht mehr nachgeladen, blieben also pixelig. Die SSD/FP schaufelte währen diese Zeit so gut wie keine Daten in den Speicher. Komischerweise sind die Textureren sofort scharf, wenn man die Sutuation neu lädt. Also kanns eigentlich nicht an der FP liegen..

      Die FPS zu begrenzen bringt tatsächlich ein wenig. Habe noch ein paar andere Tweaks getestet, aber auch die halfen nicht weiter ( zB TEXTURE_SIZE_EXP=).
      Ach ja. Mit ORBX Open LC soll sich das noch verschlimmern. Habe ich aber noch nicht getestet

      Thomas

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Major Tom ()

    • Ich klinke mich hier mal mit der selben Thematik ein: So sah es heute auf FL150 im Anflug auf LOWI aus:

      Schwamm.jpg

      Keine Ahnung was da nun wieder schief läuft, wird man mit der beschi$$enen FSX Engine nie mehr verstehen. Fakt ist, das sieht grausam aus und treibt mich in den Wahnsinn. Ich hab auch echt kein Bock mehr auf Fehlersuche.... So viel Zeit muss man erstmal haben!
      Hardware:
      Intel Pentium i7 7700k auf 4800 Promille, WageKü
      Zotac Amp! Extreme 1080 Ti GTX 11GB
      16 GB G.Skill Trident RGB
      Gigabyte Z270 HD3
      Be Quiet! 600W Straight Power Gold
      2x Samsung 850 Evo SSD 250 GB
      2x Crucial 525 GB SSD
      2x 4TB USB 3.0 Ext. Center
      Windows 10 Prof.
      3x Samsung Curved 27", 1x LG 32"
    • Also, ich habe jetzt mal den Tweak "TEXTURE_SIZE_EXP=8" hinzugefügt. Habe das Gefühl, die Texturen sind insgesamt schärfer, was schon mal gut ist. Zusätzlich habe ich "FIBER_FRAME_TIME_FRACTION=0.10" hinzugefügt, die Texturen laden bis auf einige Ausnahmen gut nach. Nun ist die Frage, welchen Wert ihr für die FIBER_FRAME_TIME_FRACTION empfehlen könnt? Welche Werte habt ihr?
    • Major Tom schrieb:

      Habe noch ein paar andere Tweaks getestet, aber auch die halfen nicht weiter ( zB TEXTURE_SIZE_EXP=).
      Wenn man den hochdreht, verschlimmert man doch das Problem, denn die Engine versucht dann, noch mehr hochauflösende Texturen reinzuladen, und kommt noch weniger hinterher. 8 ist Standard, 9 entspricht dem Menüpunkt "HD-Texturen" (o.ä.), und 10 ist dann der Overkill.

      Major Tom schrieb:

      Mit ORBX Open LC soll sich das noch verschlimmern.
      Gut möglich. OpenLC schraubt (bei gleichen Einstellungen) die Menge an Autogen hoch, soviel ich weiss.

      mr_gambler schrieb:

      Nun ist die Frage, welchen Wert ihr für die FIBER_FRAME_TIME_FRACTION empfehlen könnt? Welche Werte habt ihr?
      Ich hab 0.01, aber FPS intern begrenzt. Blurries hab ich damit keine, nur verspätetes nachladendes Autogen nur in besonders anspruchsvollen Gegenden wie New York (wird Zeit für einen 8700K ;) )
      • i7-4930K, H100, 16 GB CL9, GTX 1070, Win 7, 40" TV FullHD, TrackIR 5 & EZCA 2.6
      • P3D V4.1, FSGlobal 2010 & FMX, FTX Global & Vector & openLC EU & NA & GES & NZSI & ~ 400 airports
      • Ant's DRIF, LHC WT1, Alabeo/Carenado C152, C172, C72R, DA42, PA34, C340, C25A, PC12, ORBX LNC4, MJC DH8D, PMDG B772
      • UTL & BVAI & Traffic-GA, ASP4 & ASCA & PTA Envshade, PF3 & MCE, GSX, FSCabinCrew
    • Dimi schrieb:

      Ich hab 0.01, aber FPS intern begrenzt. Blurries hab ich damit keine, nur verspätetes nachladendes Autogen nur in besonders anspruchsvollen Gegenden wie New York (wird Zeit für einen 8700K )
      Gut, probiere das mal mit 0.01 aus, vielleicht verbessert sich ja noch was. Auf wie viel hast du die FPS beschränkt? Hast du im NVIDIA Inspector irgendwelche Änderungen durchgeführt?
    • Ich kenne mich mit dem tweaken nicht so aus. Wo müssen die denn reingesetzt werden, für den Fall der Fälle?
      Mein FLUSI:
      Intel Core I5 6600K 4x 3,5 GHz
      Kingston Hyper X Fury 16GB DDR4-2133 RAM
      Gigabyte GA-Z170-HD3P
      Festplatten 2 x 1 TB, plus 1x 512 GB SSD Harddisk
      NVIDIA GTX 980 TI 6GB
      2 x 27 Zoll Monitore, 1 x 34 Zoll Monitor, 1 x 19 Zoll Monitor
      Win 10
      P3D V4, AS16, ASCA, ORBX Pakete, FS Global Ultimate NG, GSX, FSUIPC, PFPX, Topcat, Navigraph Abo, PMDG B737 NGX, Saitek Flightyoke Pro, Rudder Paddels, TQ, 2 x Funkgeräte, 1 x Multipanel, 1 x Switchpanel, Opencockpits MCP, 2x Opencockpits EFIS
    • Scotty6986 schrieb:

      Ich klinke mich hier mal mit der selben Thematik ein: So sah es heute auf FL150 im Anflug auf LOWI aus:

      Schwamm.jpg

      Keine Ahnung was da nun wieder schief läuft, wird man mit der beschi$$enen FSX Engine nie mehr verstehen. Fakt ist, das sieht grausam aus und treibt mich in den Wahnsinn. Ich hab auch echt kein Bock mehr auf Fehlersuche.... So viel Zeit muss man erstmal haben!
      So sah es bei mir auch am Anfang an
      Problem ist das OC der CPU, ich hatte auch meine i7-7700k auf 4.8 gebracht, hatte zwar 20fps mehr als default, aber dafür hatte ich sehr unscharfe Texturen auf P3D v4.0
      Sobald ich die CPU auf default gestellt habe, alles perfekt, aber dafür hatte ich weniger FPS und auf anflüge z.B. auf EDDF v2 ca. 20 fps oder KLAX 18-20fps

      Mit der i5-8600k habe ich jetzt keine Problemen mehr