Packflow Schalter zum steuern eines Gebläses

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Meine Lüfter sind da und machen ordentlich Luftdruck. So habe ich mir das vorgestellt. Ich führe meine Doku hier weiter:
      aviation.pero-online.de/wordpress/?p=1984

      Hoffe, dass ich WE die Software fertig machen kann, dann findet Ihr dort alle Downloads und den Code für das Arduino.
      Greetings,
      pero
      ___________________________________
      : : : aviation.pero-online.de
      Developer of SIMstarter NG & Homecockpit Builder
    • So meine Doku ist fertig, die Software kann ebenfalls heruntergeladen werden.
      aviation.pero-online.de/wordpress/?p=1984

      Man kann die Software auch ohne ARDUINO einsetzen, wenn man über die Serielle Schnittstelle die Befehle verarbeiten kann:

      Quellcode

      1. pFlowLO = Schalter hat LO Stellung
      2. pFlowNORM = Schalter hat NORM Stellung
      3. pFlowHI = Schalter hat HI Stellung
      4. fanON = Software sendet On Befehl
      5. fanOff = Software sendet Off Befehl
      Nun bleibt noch offen, wie und wo ich die Lüfter installiere. Mal sehen.
      Greetings,
      pero
      ___________________________________
      : : : aviation.pero-online.de
      Developer of SIMstarter NG & Homecockpit Builder
    • Hi Cpt. Pero,
      Meinst du, du kannst mir den Arduinocode so umbauen, dass ich damit zwei Relais (5V Normal und 12V high ) ansteuern kann? Und bei jedem schalten ein kurzer Delay (250-500) wegen Rücklaufstrom (Freilaufdiode hab ich trotzdem) drin ist? :love:
      Gruß Florian
      facebook.com/A320Homecockpit
      Bau eines A320 Homecockpits.
      Gigabyte Z87X- D3H, i5 4670K@ 3,40 GHz Watercooled, 16GB Ram, NVidia GeForce GTX980 Ti AMP Zotac
      Win7 Professional (64bit), Prepare 3D V4.1
      ASP4+ASCAD
      Jeehell, TOPCAT, GSX, EFASS

      Weitere Hard und Software siehe Profilinfo
    • Kleiner Nachtrag. Ich hab gerade mal deine Software runtergeladen nur leider startet diese nicht. :( Der Virenscanner is auch erstmal angesprungen. O.o
      Vielleicht ne Idee?
      Liebe Grüße
      Florian
      Gruß Florian
      facebook.com/A320Homecockpit
      Bau eines A320 Homecockpits.
      Gigabyte Z87X- D3H, i5 4670K@ 3,40 GHz Watercooled, 16GB Ram, NVidia GeForce GTX980 Ti AMP Zotac
      Win7 Professional (64bit), Prepare 3D V4.1
      ASP4+ASCAD
      Jeehell, TOPCAT, GSX, EFASS

      Weitere Hard und Software siehe Profilinfo
    • Nochmal ein Nachtrag... Sorry. :D
      Lass das erstmal mit dem Relais-Sketch. Ich werde deine Software mit der PWM Version probieren. Ich/Wir können ja dann später das Ganze noch mal passend zu den Relais umbauen.
      Wie gesagt, deine Software läuft aktuell noch nicht auf meinem Win7 Rechner. Ich nehme mal an, dass die eine Software-Datei das auszuführende Programm ist und keine Installationsdatei? Wenn ich darauf klicke kommt kurz der Ladekreis und das wars dann. :/
      Arduinosketch ist auf den UNO hochgeladen. Hab lediglich nur den Pin fürs PWM auf 6 (höhere Frequenz) und die Eingänge entsprechend angepasst. Im Monitor erkennt er diese auch. Allerdings bekommt der Motor kein Signal, denke mal das liegt an der nicht gestarteten Software.

      Viele Grüße
      Florian
      Gruß Florian
      facebook.com/A320Homecockpit
      Bau eines A320 Homecockpits.
      Gigabyte Z87X- D3H, i5 4670K@ 3,40 GHz Watercooled, 16GB Ram, NVidia GeForce GTX980 Ti AMP Zotac
      Win7 Professional (64bit), Prepare 3D V4.1
      ASP4+ASCAD
      Jeehell, TOPCAT, GSX, EFASS

      Weitere Hard und Software siehe Profilinfo
    • Tcane schrieb:

      Nochmal ein Nachtrag... Sorry. :D
      Lass das erstmal mit dem Relais-Sketch. Ich werde deine Software mit der PWM Version probieren. Ich/Wir können ja dann später das Ganze noch mal passend zu den Relais umbauen.
      Wie gesagt, deine Software läuft aktuell noch nicht auf meinem Win7 Rechner. Ich nehme mal an, dass die eine Software-Datei das auszuführende Programm ist und keine Installationsdatei? Wenn ich darauf klicke kommt kurz der Ladekreis und das wars dann. :/
      Arduinosketch ist auf den UNO hochgeladen. Hab lediglich nur den Pin fürs PWM auf 6 (höhere Frequenz) und die Eingänge entsprechend angepasst. Im Monitor erkennt er diese auch. Allerdings bekommt der Motor kein Signal, denke mal das liegt an der nicht gestarteten Software.

      Viele Grüße
      Florian
      Ja, einen Ausgang auf dem Arduino auf "HIGH" zu setzen ist natürlich überhaupt kein Problem. Er schaltet dann mit 5V. Okay?
      Es kann sein, dass .NET Version nicht mit Win7 kompatibel ist. Kann ich aber recht einfach v4 compatible machen, die Libs sollten passen.

      Mein Programm ist direkt die Software.

      Der Motor bekommt kein Signal? Klemm doch mal eine Diode (2,2V mit 220 Ohm Widerstand) and den PIN 6 und GND. Wenn die gedimmt wird, sollte es klappen.
      Greetings,
      pero
      ___________________________________
      : : : aviation.pero-online.de
      Developer of SIMstarter NG & Homecockpit Builder
    • Ja, wie gesagt, mach mal keinen Stress. Ich probier das jetzt erstmal mit dem Mosfet (muss ich halt kühlen) und PWM.
      Wäre klasse, wenn du deine Software Win7 kompatibel machen kannst. ;) Glaube auch, dass es daran liegt.
      Motor bekommt schon Signal. Mit einem kurzen Testsketch funktioniert er auch.
      Es liegt einfach daran, dass der Sketch ja keine Befehle (FanOn oder FanOff) bekommt und dadurch einfach aus bleibt. Wenn ich im Seriellen Monitor FanOn eingebe, geht er auch an und ich kann mit dem Packflowschalter wie gewollt die einzelnen Geschwindigkeiten einstellen. Der Sketch tut einfach nur das, was er tun soll. :D
      Es hapert einfach gerade nur am starten deiner Software. ;)

      Viele Grüße
      Florian
      Gruß Florian
      facebook.com/A320Homecockpit
      Bau eines A320 Homecockpits.
      Gigabyte Z87X- D3H, i5 4670K@ 3,40 GHz Watercooled, 16GB Ram, NVidia GeForce GTX980 Ti AMP Zotac
      Win7 Professional (64bit), Prepare 3D V4.1
      ASP4+ASCAD
      Jeehell, TOPCAT, GSX, EFASS

      Weitere Hard und Software siehe Profilinfo
    • Also bei mir sollte das durch diverse AddOn Installationen eigentlich auf dem aktuellsten Stand sein.
      Gruß Florian
      facebook.com/A320Homecockpit
      Bau eines A320 Homecockpits.
      Gigabyte Z87X- D3H, i5 4670K@ 3,40 GHz Watercooled, 16GB Ram, NVidia GeForce GTX980 Ti AMP Zotac
      Win7 Professional (64bit), Prepare 3D V4.1
      ASP4+ASCAD
      Jeehell, TOPCAT, GSX, EFASS

      Weitere Hard und Software siehe Profilinfo
    • Neu

      Guten Morgen,

      ich habe nun mal in .NET Framework 4 compiliert. Jetzt sollte es unter Win 7 auf alle Fälle laufen. Vorher war es 4.5.1, was auch mit Win 7 compatibel ist, wenn man auf dem aktuellen .NET Stand ist.
      Läuft es nun?
      Dateien
      Greetings,
      pero
      ___________________________________
      : : : aviation.pero-online.de
      Developer of SIMstarter NG & Homecockpit Builder
    • Neu

      Hi,
      Ich muss dich leider enttäuschen, funktioniert immer noch nicht. Ich glaube auch nicht, dass es am net liegt, da ich wie gesagt die aktuellste net Version bereits installiert habe.
      Viele Grüße
      Florian
      Dateien
      • Net.PNG

        (82,29 kB, 2 mal heruntergeladen, zuletzt: )
      Gruß Florian
      facebook.com/A320Homecockpit
      Bau eines A320 Homecockpits.
      Gigabyte Z87X- D3H, i5 4670K@ 3,40 GHz Watercooled, 16GB Ram, NVidia GeForce GTX980 Ti AMP Zotac
      Win7 Professional (64bit), Prepare 3D V4.1
      ASP4+ASCAD
      Jeehell, TOPCAT, GSX, EFASS

      Weitere Hard und Software siehe Profilinfo